OSPF PROTOCOL OVERVIEW AND BASIC CONCEPTS,OSPF TERMINOLOGY AND OPERATION

OSPF PROTOCOL OVERVIEW AND BASIC CONCEPTS: BASIC OSPF LAB, OSPF AREAS, TOPOLOGY & ROUTING TABLE, OSPF TERMINOLOGY AND OPERATION

 

OSPF Overview -:

Open Shortest Path First (OSPF) is a dynamic routing protocol and it’s also called is an Interior Gateway Protocol (IGP) and widely used in large and complex Enterprise networks.

OSPF is an open standard routing protocol and can be used in multi-vendor network environment. It is a link-state routing protocol use SPF algorithm to calculate the best routes and updates routing table. It supports n numbers of hop counts.

OSPF is a very scalable and provides fast routing convergences between OSPF routers. OSPF uses metric as cost from interface. OSPF default administrative distance (AD) is 110. OSPF uses multicast addresses 224.0.0.5 and 224.0.0.6 for routing updates.

OSPF Terminology and Operation

Area

OSPF Routing designed with Areas. An OSPF internetwork is subdivided into areas and configured at least with one area called Area 0. An OSPF area is a logical group of routers and networks. In an area, every router has identical topology databases. The benefits of creating area to reduces the number of link-state advertisements (LSA) and other OSPF overhead traffic sent on the network. It also controls the size of topology and the routing table that each router maintains in the OSPF domain.

Area 0

OSPF Area 0 is also known as backbone area and each area must be connected to backbone area (area 0). Area 0 work as transit areas for inter-area transit routing and the distribution of routing information between areas. Every router in area 0 known as transit routers.

Area Border Routers (ABRs)

ABR Routing devices connected to more than one OSPF area and at least one interface must be connected to backbone Area 0.ABR Router also maintain a separate topological database for each area to which they are connected.

OSPF Router Types

  • Internal Router OSPF Router it all interfaces connected to the same area. Internal routers share LSDB (Link state Database).
  • Area Border Router OSPF Router it interfaces connected to other areas. ABR Router maintains multiple LSDBs, one for each attached area.
  • Backbone Router OSPF Router with at least interface connected to Area 0. This includes all ABR and internal routers of the backbone area.
  • AS Boundary Router (ASBR) A router that connected to external AS outside OSPF AS. SBRs advertise external routes throughout the OSPF AS

LSA

OSPF Router uses a LSDB (link state database) to maintains its Routing tables. LSAs build up the OSPF link state database called LSDB. All the routers in an OSPF domain exchanges LSA’s packets which it contains the link state Database information.

LSA Types-:

  • LSA Type 1   – OSPF Router LSA – Generated by every router for each link that belongs to an Area
  • LSA Type 2   – OSPF Network LSA – Generated by Designated Router (DR)
  • LSA Type 3   – OSPF Summary LSA – Generated by Area Border Routers (ABRs)
  • LSA Type 4   – OSPF Summary ASBR LSA – Generated by ABR, This Type of LSA contains routes to ASBR
  • LSA Type 5   – OSPF Autonomous system external LSA – Generated by ASBR
  • LSA Type 6   – OSPF Multicast LSA – LSA 6 is used for multicast applications
  • LSA Type 7   – OSPF NSSA (Not So Stubby Area)  – Generated external routes are advertised by type 5 LSA
  • LSA Type 8   – External attribute LSA for BGP – External attributes LSA for Border Gateway Protocol (BGP
  • LSA Type 9   – OSPF Link-local Opaque LSAs
  • LSA Type 10 – OSPF Area-local Opaque LSAs
  • LSA Type 11 – OSPF AS Opaque LSAs

 

OSPF Router ID

OSPF Router ID is an IPv4 address (32-bit) assigned to each router running the OSPF protocol.OSPF Router ID (RID) must be configured unique for each router in the OSPF Network. Router ID will be selected as highest IP address of any of its configured interfaces.

OSPF uses the following criteria to select the Router ID

  • Manual configuration of the router ID on OSPF Router.
  • OSPF Router select highest IP address of a loopback interfaces on a Router.
  • OSPF Router select highest IP address of a Physical interfaces on a Router .

OSPF Features

  • OSPF is an open standard routing protocol (supports multi-vendor’s router)
  • OSPF link state routing protocol
  • OSPF provides equal-cost multipath routing.
  • OSPF is support n number of hops.
  • OSPF subdivided into area.
  • OSPF is a multicast routing protocol
  • OSPF use SPF algorithm to calculate the best routes.
  • OSPF provides fast routing convergences and scalability.
  • OSPF don’t sent periodic update like RIP. It uses less bandwidth since transmission take place only when routing changes occur.
  • OSPF uses metric as cost from interface
  • OSPF maintain three table – Routing table, Topology table and Neighbor table
  • OSPF is a classless routing protocol supports CIDR, VLSM (Variable Length Subnetting).

 

OSPF Lab –

OSPF Quick GNS3 Lab designed with 3 Routers connected point to point. All the router enabled OSPF routing with AREA 0.

 

Figure – Basic OSPF Lab for CCNA Student

 

Configuration -:

New-York#

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 description connected to London Location
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description connected to Paris Location
 ip address 172.20.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Ethernet1/0
 description conneted to New York Lan
 ip address 10.1.1.1 255.255.255.0
 half-duplex
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 172.20.1.0 0.0.0.3 area 0
 network 192.168.1.0 0.0.0.3 area 0

 

London#
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
!
interface FastEthernet0/0
 description connected to New York Router
 ip address 192.168.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 192.168.200.1 255.255.255.0
 half-duplex
!
router ospf 2
 log-adjacency-changes
 network 172.16.1.0 0.0.0.3 area 0
 network 192.168.1.0 0.0.0.3 area 0
 network 192.168.200.0 0.0.0.255 area 0
!

 

Paris#
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface FastEthernet0/0
 description connected to London Location
 ip address 172.16.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description connected to New York Location
 ip address 172.20.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface Ethernet1/0
 description connected to Paris Lan
 ip address 172.30.1.1 255.255.255.0
 half-duplex
!
router ospf 3
 log-adjacency-changes
 network 172.16.1.0 0.0.0.3 area 0
 network 172.20.1.0 0.0.0.3 area 0
 network 172.30.1.0 0.0.0.255 area 0
!

 

Validate IP Routing Table

New-York#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     172.16.0.0/30 is subnetted, 1 subnets
O       172.16.1.0 [110/2] via 192.168.1.2, 00:00:17, FastEthernet0/0
                   [110/2] via 172.20.1.2, 00:00:17, FastEthernet0/1
     172.20.0.0/30 is subnetted, 1 subnets
C       172.20.1.0 is directly connected, FastEthernet0/1
     172.30.0.0/24 is subnetted, 1 subnets
O       172.30.1.0 [110/11] via 172.20.1.2, 00:00:17, FastEthernet0/1
O    192.168.200.0/24 [110/11] via 192.168.1.2, 00:00:19, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Ethernet1/0
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/0
New-York#

 

Connectivity Testing and Verifications

New-York#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.2           1   FULL/BDR        00:00:34    192.168.1.2     FastEthernet0/0
1.1.1.3           1   FULL/BDR        00:00:37    172.20.1.2      FastEthernet0/1
New-York#
New-York#sh ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         133         0x80000004 0x00CCC8 3
1.1.1.2         1.1.1.2         114         0x80000003 0x006E06 3
1.1.1.3         1.1.1.3         114         0x80000003 0x00C860 3
172.30.1.1      172.30.1.1      684         0x80000003 0x00D5C5 3
192.168.1.1     192.168.1.1     1130        0x80000002 0x004780 3
192.168.200.1   192.168.200.1   667         0x80000004 0x00D046 3

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.1.2      1.1.1.3         114         0x80000001 0x003537
172.20.1.1      1.1.1.1         133         0x80000001 0x001557
192.168.1.1     1.1.1.1         133         0x80000001 0x000BB9
New-York#

New-York#ping 192.168.200.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/28/32 ms

New-York#ping 172.30.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/28/32 ms
New-York#

 

Conclusion -:

This article describes the basic OSPF Terminology and Operation. We have built reference GNS3 Lab on Basic OSPF Routing for CCNA networking students. This OSPF Lab built on GNS3 platform. Network design included 3 cisco 3600 series routers IOS Version 15.0(1r)M16. All routers are connected point to point network and implemented OSPF with AREA 0.

 

TAG     – OSPF PROTOCOL OVERVIEW, LSA, OSPF AREA , OSPF GNS3 LAB , OSPF CONFIGURATION , OSPF FEATURES

Author: Ronnie

Leave a Reply